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Installing and configuring PhoneGap/Cordova

Lab objectives

The purpose of this lab is to install and configure an IDE for building hybrid

applications with PhoneGap.

Time estimate

You should be able to complete the lab in around 45 minutes.

Prerequisites

Appropriate Skill Level:
« No prerequisite skills required

Computer Specification:
« Android SDK installed
« Java SDK installed
« Internet connectivity

Getting started
This lab includes the following:
« Installing and configuring the IDE
 Building and testing your first PhoneGap application

Setting up PhoneGap

In this lab, we will install the following components:
Eclipse Indigo
Eclipse Plugin for Android Development Tools
Apache ANT
Ruby
PhoneGap

Your moderator will provide you with the required install files for all of these

components.
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Installing and configuring PhoneGap/Cordova

1. Unzip the eclipse-java-indigo-SR1-win32.zip file.

2. Unzip the phonegap-phonegap-1.5.0-0-gde1960d.zip file.

Step 3 to 5 is optional — because we skip the step of compiling our own
packages here and use the precompiled stuff instead.

3. Unzip the apache-ant-1.8.2-bin.zip file.
4. Run rubyinstaller-1.9.3-p125.exe to install Ruby.

5. Run Git-1.7.9-preview20120201.exe to install GIT. Do a default installation
without changing anything.

6. Start Eclipse and accept the default workspace:

x]

& Workspace Launcher

Select a workspace

Eclipse stores wour projects in a Folder called a workspace,
Choose a workspace Folder to use For this session,

I\ Documents and Settingstadministratorbworkspace

Workspace: | V| [ Browse, .

[Cuse this as the default and do not ask again

(0] 4 ] [ Cancel

Page 4 of 16



Installing and configuring PhoneGap/Cordova

Downloading the ADT Plugin

7. Use the Update Manager feature of your Eclipse installation to install the
latest revision of ADT on your development computer:

7.1. Start Eclipse, then select Help > Install New Software....
7.2. Click Add, in the top-right corner.

7.3. In the Add Repository dialog that appears, enter "ADT Plugin" for the
Name and the following URL for the Location:

https://dl-ssl.google.com/android/eclipse/

& Add Repository E]
Mame; ADT plugin
Location: | htkp:fidl-ssl google, comyandroid/eclipse/
':_?:' l Ok ] [ Cancel ]
7.4.Click OK

7.5. In the Available Software dialog, select the checkbox next to Developer
Tools and click Next.

Mame Wersian

= [«] 000 Developer Tools
-{l:‘: android DDMS 17.0.0.+201203161636-291553
Lt Android Development Tools 17.0.0.v201203161636-291853
-{l::‘: android Hierarchy Yiewer 17.0.0.%201203161636-291853
i android Traceview 17.0.0,v201203161636-291853

7.6. In the next window, you'll see a list of the tools to be downloaded. Click
Next.

7.7. Read and accept the license agreements, then click Finish.

8. When the installation completes, restart Eclipse.
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Installing and configuring PhoneGap/Cordova

Configuring the ADT Plugin

9. Now we need to modify your ADT preferences in Eclipse to point to the
Android SDK directory:

9.1. Select Window > Preferences... to open the Preferences panel.
9.2. Select Android from the left panel.

9.3. You may see a dialog asking whether you want to send usage statistics
to Google. If so, make your choice and click Proceed. You cannot continue
with this procedure until you click Proceed.

9.4. For the SDK Location in the main panel, click Browse... and locate your
downloaded SDK directory.

Prafarance =
| €3 Value must be an existing direckory - -

e |
g A:;re;:; Android Preferences

Build SDK Location: | | ’ Browse. ., ]

EETS Moke: The list of SDE Targets below is only reloaded once you hit ‘&pply’ ar 'OK',

itars

Laurch Browse For Folder @ Platform | AP...

Lint Error Checking

LogCak

Usage Skats
Ank
Help Iflnd [= e Mew Volume (E:) -~
Instalflpdate = (£ ANDROID_SDK_R16
Java - -
Maven andraid-sdk-windows
Mylyn [ add-ons
Run/Debug () platForms
Team ) platform-taols E
Usage Data Collector =) samples

Yalidation (3 temp
‘WindowBuilder [ tools
HML I5) APACHE _AMT 2
— T - —
< | =
Folder: | android-sdk-windows |
[ Make Mew Folder ] [ a4 l [ Cancel ] @ Apply

@ [ul 4 Zancel

9.5. Click Apply, then OK. If finished, exit Eclipse.
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Modifying your environment variables

Prepare your environment by extending your PATH by the following:

your_system_path/jdk/bin
your_system_path/android-sdk/tools
your_system_path/ruby/bin
your_system_path/apache-ant/bin

You will also need to have the following attributes defined:
JAVA HOME - path of your JDK directory

ANT_HOME - path of you apache-ant directory
ANDROID_HOME - path to your android SDK directory.

System variables
YWariable YWalue -
AMDROID_HOME — EXNANDROID_SDE_R16%android-sdk-win. ..
ANT_HOME E:APACHE_AMT'\apache-ant-1.8.2
ZomSpec W IRDOYW S systemnm 32 cmd  exe
FP_MO HOST C... NO
1ava_HOME Z:\Program Files)Javaljdkl.6.0_31 hd
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Your first PhoneGap project

1. Start Eclipse and create a new Android project via File > New > Other >
Android > Android Project.

Wizards:

*- = General
== Android
ﬁ Android Icon Set
'[Gg Android Project
Gg Android Sample P
JEI android Test Proj
| Android XML File

rojeck
eck

2. Provide a name for the new project and click Next.

3. Select the GALAXY Tab Addon as the Build Target and click Next.

Select Build Target
“hoose an 50K ko target

Build Target

Target Mame

[] android 2.2

[ oTs Add-On

[ realzD Add-On
GALAXY Tab Addon

vendaor

Android Open Source Project
ENOQCERS Corporation

LiGE

Samsung Electronics Co,, Lid,

PlakFarm

2.2
2.2
2.2
2.2

C

APL...

g
=]
=]
=]

4. Provide a Package Name (e.g. demo.phonegap.sample) and click Finish.

5. Now we need to add the PhoneGap library to the project's build path. Right
click on the project and select Build Path-> Add external archive.

6. Select the cordova-1.5.0.jar from your libs folder and click Open.

JAR Selection

Look in: | I android

By I example

! :3 )l

T mmet s b

by Becent @ cordova-1.5.0.jar
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7. Right-click on the project's assets directory and create a new folder www
within.

Enter or select the parent Folder:

PhoneaaP3amplefassets

o
+ T:Gl- Demo
= I:g- PhoneGAPsample
= settings

Gl,::v gen [Generated Java Files]
22 res
= src

g o Y e

Folder name: | waw

8. Within the www folder, create a new file index.html.

Enter or select the parent Folder:

PhoneaAPsample) assets i

+ Tél- Dermo
= Té'- PhoneGaPsample

=+ .settings

= GIC? asseks
= [

GIC? bin
GL,:: gen [Generated Java Files]
GE? res
== arc

Ry By By

File name: | index.hkml

9. Open the index.html file with a text editor (Right-click > Open with > Text
Editor).
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Installing and configuring PhoneGap/Cordova
10. Add the following code here:

<!DOCTYPE html>
<html>
<head>
<title>Capture Photo</title>

<script type="text/javascript" charset="utf-8" src="cordova-
1.5.0.3s8"></script>

<script type="text/javascript" charset="utf-8">
var pictureSource; // picture source

var destinationType; // sets the format of returned value

// Wait for PhoneGap to connect with the device
//

document.addEventListener ("deviceready",onDeviceReady, false) ;

// PhoneGap is ready to be used!

//

function onDeviceReady () {
pictureSource=navigator.camera.PictureSourceType;

destinationType=navigator.camera.DestinationType;

// Called when a photo is successfully retrieved
//
function onPhotoURISuccess (imageURI) {

// Uncomment to view the image file URI

// console.log (imageURI) ;

// Get image handle
//

var largeImage = document.getElementById('largeImage');

// Unhide image elements
//
largelImage.style.display = 'block';

// Show the captured photo

// The inline CSS rules are used to resize the image
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//

largeImage.src = imageURI;

// A button will call this function
//
function getPhoto (source) {
// Retrieve image file location from specified source
navigator.camera.getPicture (onPhotoURISuccess, onFail,
destinationType: destinationType.FILE URI,

sourceType: source });

// Called if something bad happens.
//

function onFail (message) {

alert ('Failed because: ' + message);

</script>

</head>
<body>

{ quality: 50,

<button onclick="getPhoto (pictureSource.PHOTOLIBRARY) ; ">Access my Photo

Library</button><br>

<button onclick="getPhoto (pictureSource.SAVEDPHOTOALBUM) ; ">Access my Photo

Album</button><br>
<img style="display:none;" id="largeImage" src="" />
</body>
</html>
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Installing and configuring PhoneGap/Cordova

11. Add the cordova-1.5.0.js to your www folder (via Right-click on the folder >
Import > General > File System).

=1 PhoneGAPSample
=2 src
=8 demo.phonegap.sample
+ m PhoneGAPSamplesctivity . je
+ Gﬁ gen [Generated Java Files]
B, GALAXY Tab Addon [Andraid 2.2]
B, Andraoid Dependencies
=B Referenced Libraries
+ I°I=~'> phonegap-1.4.1.ar - E:PHOM
GL,:'E- asseks
+ GL,:'E- bin
5 res
==
@ index.html
EE:E phonegap-1.4.1.js

7 AndroidManifest, xmi
=5 e Cicid Ccio Lo

12. Add a new libs folder on project root level. Import the cordova-1.5.0.jar file
into this folder.

+ G@bin

=2 libs
Lﬂ cordova-1.5.0.jar

#-32 res
<1 androidManifest . xml
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13. Import the xml folder from your PhoneGap download into the res directory.

14.

File system

Import resources From the local file system,

From directory: | EX1PHONEGAP1S\phonegap-phonegap-de1260dylibl android

= D@ ] @cordova-l.S.D.jar
#-[] = example F cordova—l.S.D.js
#- ] (= [ 2/ noTIcE

[ &l rREADME.md

b Browse. .,

= res

+-[= drawable-hdpi
= drawable-ldpi
= drawable-mdpi
= drawable-xhdpi
= layout
= walues
== gl

1 cordova.xml

F -

7 plugins, xml

Open the Java class that has been generated on project creation.

package demo.phonegap.ssunple;

Fimport android.app.ictivity:

public class PhoneGAPSamplelictivity extends Activicy |
%% Called when the activity is first created. #/
@rverride
public rvoid onCreate (Bundle savedInstanceltate)]
super.onCreate [savedInstance3tate)
secContentView (R. layout..main) ;
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Installing and configuring PhoneGap/Cordova
15. Change the code as follows:

Our class should extend DroidGap instead of Activity.
Remove the setContentView line and add the following here:

super.loadUrl ("file:///android asset/www/index.html");

16. Hit STRG+SHIFT + O to organize your imports and remove the issues.

package demo.phonegap.sample;
import android.os.Bundle:;
import cow.phonegap.DroidGap;

public class PhoneGiPSampleletivity extends DroidGap {
f#% Called when the activicy iz first created. */
Brverride
public void onCreate (Eundle savedInstanceltate] |
super.onCreate (savedInstanceitate) ;
super.loadUrl ("file:///android asset/www/index.}

17. Save your code.

18. Navigate to the AndroidManifest.xml and open it with a text editor.
Within this file, navigate to the

android:versionName="1.0" >

line and add the following set of permissions afterwards:

<supports-screens android:largeScreens="true"
android:normalScreens="true" android:smallScreens="true"
android:resizeable="true" android:anyDensity="true" />

<uses-permission android:name="android.permission.CAMERA" />
<uses-permission android:name="android.permission.VIBRATE" />

<uses-permission
android:name="android.permission.ACCESS COARSE LOCATION" />

<uses-permission android:name="android.permission.ACCESS FINE LOCATION"

/>

<uses-permission
android:name="android.permission.ACCESS LOCATION EXTRA COMMANDS" />
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Installing and configuring PhoneGap/Cordova

<uses-permission android:name="android.permission.READ PHONE STATE" />
<uses-permission android:name="android.permission.INTERNET" />
<uses-permission android:name="android.permission.RECEIVE SMS" />
<uses-permission android:name="android.permission.RECORD AUDIO" />

<uses-permission
android:name="android.permission.MODIFY AUDIO SETTINGS" />

<uses-permission android:name="android.permission.READ CONTACTS" />
<uses-permission android:name="android.permission.WRITE CONTACTS" />

<uses-permission
android:name="android.permission.WRITE EXTERNAL STORAGE" />

<uses-permission android:name="android.permission.ACCESS NETWORK STATE"
/>

<uses-permission android:name="android.permission.GET ACCOUNTS" />

<uses-permission android:name="android.permission.BROADCAST STICKY" />

19. Add the following activity declaration:

<activity

android:name="com.phonegap.DroidGap"
android:label="@string/app name"
android:configChanges="orientation|keyboardHidden">
<intent-filter>
</intent-filter>

</activity>

<application

android: icon="Fdlrawable/ic launcher"

android: label="@string/app name" >

<activity
android: name=", PhoneGAPSamplaedctivity"
android:label=”@stringf&pp_name" =
<intent-filter:>

<caction android:name="android. intent. 2ction. MATN" />

<oategory android: name="gndroid.intent . category. LAVNCHER!'
</intent-filter:>
<factivitys
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Installing and configuring PhoneGap/Cordova
Testing your application

1. Right-click on our project and select Run As > Android Application.

Note that the device starts more quickly than the first time and takes you
wherever you were on the device at the time you closed it down.

2. Your application should start, providing access to the local photo album &
library of the device.

e o Fl] €8 2:08¢m

Access my Photo Library |

Access my Photo Album

Summary

In this lab, you installed and configured the PhoneGap development
environment. You built and tested your first application

End of exercise
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